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1. Overview 

The Utility Manager is an application that is used to launch or HMI programming software Easybuilder pro 

and other useful applications. This document introduces applications that are available with cMT HMIs. 

 
1. Launch Utility Manager. 

2. Select Model menu. Click on the upper left corner of Utility Manager, select [cMT Series] menu.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3. Utility Manager will list the available applications for cMT HMIs. 

 
  



 4  

Design menu- 
 

• Easybuilder pro: This is the HMI programming software. Open this application to create or 

edit projects for cMT HMIs. 

• EasyAddressViewer: This application lists the supported addresses for the PLCs and controllers. 

Programmers can refer to the lists and determine if the desired addresses are supported in this 

version of Easybuilder pro. It recommends that programmers understand what the address 

format looks like before beginning projects. 
 

• Simulation: This application can simulate an HMI project on a PC with real testing (Online- 

simulation) or non-real testing (Offline-simulation). This way, users don’t need to load the project to 

cMT HMI. 

 

Analysis & Testing menu- 
 

• EasyWatch: This application allows users to create a table that monitors data in cMT HMIs and 

PLCs that are connected to the HMI via Ethernet connection. 

• cMT Diagnoser: This application can be used to troubleshoot communication issues. 

• Reboot: This application can restart a HMI via Ethernet or USB connection.  
• Serial pass-through: This application allows the PC application to communicate to the PLC 

through the cMT HMI. In this case, the HMI acts as an adapter. 

• Ethernet pass-through: This application allows the PC application to communicate to the PLC 

through the cMT HMI. In this case, the HMI acts as an ethernet adapter. 

 

Publish menu- 
 

• Download: This application can load a project, runtime, recipe, and startup screen image to a 

cMT HMI via Ethernet or USB connection. 

• Upload: This application can retrieve the project of a cMT HMI and historical data stored in the 

cMT HMI. 

 

Maintenance menu- 
 

• Administrator Tool: This application can build data for [User Account], [USB Security Key], 

[SMTP Server Setting], and [e-Mail Contacts] to a USB drive. 

• cMT-Viewer: This application can connect to a cMT HMI to view and control the HMI.  
• cMT-iV5/ iV6 OS Upgrade: This application can update the OS of cMT-iV5 and cMT-iV6. 
• cMT-Server OS Upgrade: This application can update the OS of cMT-SVR-100 and cMT-SVR-200  
• Codesys Firmware Upgrade: This application can update the firmware of Codesys HMI. 

 

Data Conversion menu- 
 

• Recipe Database Editor: This application allows users to edit a recipe database (*.db file) 

without modifying the cMT HMI project itself. 

• EasyConverter: This application can convert data log files (*.db) and event log files (*.db) to 

CSV format files (*.csv). 
 

• Recipe Editor: This application can allows users to edit recipe data stored in RW and RW_A 

retentive memory, as well as data stored in EM extended memory. 
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Utilities Non-cMT Models cMT Models cMT Gateway 

(cMT-Gxx, cMT-CTRL01) 
Easybuilder pro V V V 
EasyAddressViewer V V V 
Simulation V V V 
EasyWatch V V V 
cMT Diagnoser  V V 
Reboot V V V 

Serial pass-through V V V 

Ethernet pass-through  V V 

Download V V V 
Upload V V V 
EasyPrinter V   
Administrator Tool V V V 
cMT-Viewer  V  

cMT-iV5/ iV6 OS Upgrade  V  

cMT-Server OS Upgrade  V  

Codesys Firmware Upgrade  V V 

Recipe Database Editor V V V 

EasyConverter V V V 
Recipe Editor V V V 
EasySystemSetting V V  
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2. Easy Address Viewer 
 
1. Launch Easy Address Viewer  

2. Select a communication driver from the drop-down list. 

3. View address type, memory format, and memory range. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note:  

1. Memory range may vary based on the controller models. 

2. The Easy Address Viewer doesn’t display free-tag based PLCs, please refer to the connection guide to get 

the information. 

 

  



 7  

3. Simulation 
 
1. Launch Simulation. 

2. Click on the “folder” icon and open a compile project (*.cxob) 

3. Click on-line simulation or off-line simulation to start simulator. Before starting on-line simulation, make 

sure the controller already connects to the PC via Ethernet or serial connection. 

 

 

 

 

 

 

4. cMT-Viewer (simulator) will pop up to simulate the project. 

 
Note:  

1. The on-line simulation lasts 10 minutes to simulate the communication between PC and PLCs. Once the 

time is up, the simulator stops communicating to the PLC. 

2. In on-line/off-line simulation, the diagnostic tool “cMT Diagnoser” can be opened via clicking the right 

mouse button. For more information, please refer to cMT Diagnoser User Manual. 
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4. EasyWatch 
 
EasyWatch allows users to monitor data in the HMI or the PLC via Ethernet from the PC. 

 

1. Launch EasyWatch. 

2. Click on [object] tab» [HMI monitor] or the shortcut button to open HMI Manager. 

 
 
 
 
 

3.Click on the Add button to add an existing cMT HMI. Enter its IP address and port number. 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 

Note: The port number is configured in EasyBuilder pro» System setting » [Model] tab. Checking “Support… 

EasyWatch” and configuring a port number to the box are required. 

 

 

 
 
 
 
 
 
 
 
 
4. After clicking OK button, the HMI will be listed in HMI Manger.  Repeat the step 3 to add multiple cMT 
HMIs. Click Exit button to close the window. 
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5. Click on [objects] tab» [Add object] » [Add Monitor] or the shortcut button to open Monitor settings. 

 
 

6.  Configure Monitor Settings, as shown below. 
Name: Give a name. 
HMI: Select the HMI. 
Device: Select the communication driver. Enter its IP address for Ethernet connection or com parameters 
for serial connection. 
Address: Enter the address to monitor. 
Address Mode: Select the data type of the address. 
Update cycle: Select the update rate of the data. 
Click OK button to confirm. 
Repeat this step for each register or bit data you want to monitor. 
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7. Select the data from the below list and then click on the Run button to start monitor. The data will be 
displayed on Value column. If needing to stop monitor, click on the Stop button. 

 
 

8. To save this EasyWatch project, Click on [File] » [Save as]. 
 
Note:  
1.When the system register [LB-9044 (disable remote control)] or [System Parameter Settings] » [System 
Setting] » [Prohibit remote HMI connecting to this machine] is enabled, the feature of monitoring in 
EasyWatch will be unavailable.  
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5. Reboot 
 
It can reboot cMT HMIs without unplugging. After reboot, cMT HMIs return to the initial state. 
 
1. Launch Reboot. 
2. Select Ethernet connection or USB connection. Some cMT models are not equipped with USB client port, 
so the USB connection is not available in these models. 
3. On [HMI Name] tab, click on Select All button. This application will scan cMT HMIs existing in this local 
network. 
4. Select the HMI you want to reboot and then click Reboot button. 
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6. Pass-through 
 
The pass-through function allows the PC to communicate to the PLC through the HMI, without 
disconnecting the PLC from the HMI. In this case, the HMI acts as an adapter. 

 
6.1. Serial Pass-Through 
The pass-through function provides two modes when using the Ethernet connection or serial connection 
from the PC to the HMI.  
 

• Using the Ethernet pass-through (virtual com used by PC) mode:  

 
1. Launch Serial Pass-through. 
2. Select [Ethernet]. 
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3. When using the Ethernet connection, the virtual serial port driver, which acts as Ethernet-to-Serial bridge, 
is required to be installed. Click on Install button and follow the pop-up window to install. The Virtual COM 
port (PC <-> PLC) indicates the virtual COM port used on the PC. The virtual COM port can be changed to 
another one via the COM ports section of Device Manger on the PC. 
 
4. Settings of Destination HMI. 
Mode: Set the mode to Normal for most PLCs. MPI ISOTPC is used for Siemens MPI connection. 
IP: Enter the IP address of the HMI. 
Communication port: Select the TCP Port. This parameter is configured in Easybuilder pro» [System 
Parameters] » [Model] tab. 
Pass-through port: Default port number is 2000.  
PLC connection: Set the COM port on the HMI that is connected to the PLC. (COM1, COM2, or COM3) 
 
5. Click Apply button to confirm the setting and begin the pass-through mode. 
6. Launch the PLC programming software to go online. 
 
 

• Using the serial pass-through mode: 

 
[Source COM Port] is the port that connects HMI to PC. 
[Destination COM Port] is the port that connects HMI to PLC. 

 
1. Launch Serial Pass-through. 
2. Select [COM port]. 
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3. HMI IP: Enter the IP address of the HMI. 
Get HMI communication Parameters: Click this button to read the current communication settings of     
Source and Destination COM port. 
Communication port: Select the TCP Port. This parameter is configured in Easybuilder pro» [System 
Parameters] » [Model] tab. 

 
The parameters of Source COM port and Destination COM port can be configured manually. 

    Source COM port (PC -> HMI): Set the COM parameters for the HMI port that is connected to the PC.  
    Destination COM port (HMI-> PLC): Set the COM parameters for the HMI port that is connected to the PLC. 

 
4. Click Start Pass-through button to begin pass-through mode. HMI work mode indicates the current mode 
of the HMI. 

Unknown: The mode is displayed before reading the communication settings of the HMI. 
 Normal: The HMI is set to communicate with PLC and ready to pass through. 
 Pass-through: The HMI is on pass-through mode. 
 
5. Launch the PLC programming software to go online. 
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6.2. Ethernet Pass-Through 
This application allows the PC to communicate to the PLC that is on the different subnet. 
For example,  
PC’s IP is 10.1.10.5. LAN1 of the CMT HMI is 10.1.10.19. LAN2 of the CMT HMI is 192.168.1.100. PLC’s IP is 
192.168.1.112. In this way, PC can program the PLC via this application. 

 
1. Launch Ethernet Pass-through. 

 
 

2. HMI IP: Enter the LAN1 IP address of the HMI or click on […] button to scan the CMT HMI. 
HMI port number: Default port number is 8000. 
Passthrough IP: Enter the IP address of the PLC. 

 
 

3. Once clicking [Connect], the communication will be established. The success message as below 
indicates that you are ready to do pass-through. 

 
 

4. Launch the PLC programming software to go online.  
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7. Download 
This application is used to transfer a compiled project file (.*cxob) to a cMT HMI. 

 
1. Launch Download. 
2. Select Ethernet connection or USB connection. Some cMT models are not equipped with USB client port, 
so the USB connection is not available in these models. 

• To download the project file, select the Project checkbox. If this is the first project download to the 
HMI, the Runtime (Firmware) checkbox must be selected. 
Click on the “Folder” button to the right of the Project checkbox. Navigate to where the *.cxob file is 
located. 

• To download the RW, RW_A, Recipe database, Startup screen, or System settings files, navigate to 
where the corresponding file is located. 
File extension of RW:        *.rcp 
File extension of RW_A:  *.rcp 
File extension of Recipe database: *.db 
File extension of Startup screen: *.bmp 
File extension of System settings: *.conf 

 
Click on Search All button to scan your HMI. Select the HMI you want to load the project file. 
Enter the password to the Password box. The default password is 111111. 

 To erase the files stored in the HMI, select the checkboxes you want to erase. 
Click on Download button to begin. 
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8. Upload 

This application is used to retrieve a compiled project file (.*cxob) stored in a cMT HMI. 

 
1. Launch Upload. 
2. Select Ethernet connection or USB connection. Some cMT models are not equipped with USB client port, 
so the USB connection is not available in these models. 
 

• To upload the project file, select the Project checkbox and click on the “Folder” button to the right of 
the Project checkbox. Navigate to where the *.cxob file will be saved. Specify the name of the 
project file and add the file extension .cxob. 
 
Click on Search All button to scan for your HMI. You will need to select an HMI in order to retrieve 
the project file. 
Enter the password to the Password box. The default password is 111111. 
Click on Upload button to begin. 

 
Note:  
1 .The cxob file is a compiled project file. To modify the project, use the Decompile tool to extract. 
(Easybuilder pro» [File] menu » Decompile) 
2.  If “disable upload function” is enabled within the project, the cxob file won’t be allowed to retrieve and 
will show the message “error: uploading project.” 
(This option can be found on Easybuilder pro» System Parameters » [System Setting] tab) 
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• To retrieve historical data or recipe files stored in a cMT HMI, select the boxes within History and 
click on the “Folder” button. Navigate to where the files will be saved. 
The folder will contain all of the selected files. 
 
Click on Search All button to scan your HMI. You will need to select an HMI in order to retrieve the 
files. 
Enter the password to the Password box. The default password is 111111. 
Click on Upload button to begin. 
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9. Administrator Tools 
 
The administrator Tools is a utility that allows you to store data to a USB drive for User Accounts, USB 
Security Key, e-Mail SMTP Server Settings, and e-Mail Contacts. It is a convenient tool to update the data 
stored in a HMI during runtime. The data built in the USB drive can be loaded into a HMI via Function key 
object or the cMT web interface. 

 
Launch Administrator Tools. 
 

9.1. User Accounts 
The User Accounts is used to update user accounts stored in Enhance Security during runtime. 
 
Configuration 
1. Select [User Accounts] checkbox. 
2. Use the Add button to create new user accounts.  Up to 127 user accounts can be added. Click 
Remove button to erase the selected account. 
3. Enter a desired user name and a password. Select security classes that the user are accessible.  
4. The Restrict the using terms is optional. If selected, the data can only be loaded in the effective 
time interval. 
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5. Click on [Save to USB] and navigate to the USB drive. 

 

               
The file also can be stored on a PC via selecting “Folder” from the drop-down list. 

 
 

Steps to load User Accounts to cMT HMI 
1. Login to the cMT web interface. 
2. Go to [Enhanced Security] menu » [Import User Accounts] tab. 
3. Navigate to the location of the file and click Update button. 
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9.2. USB Security Key 

The USB security key is a way to login to cMT HMI without entering the user name and the password. 
To use this function, you will need to create a Function Key object that is configured to Use [USB 
Security Key].  

 
 

 
 
When the USB drive that contains the security key to the HMI is inserted and the Function key object 
is pressed, the HMI will check if the user name and password stored in the USB drive matches an 
existing account in the HMI.  
 
 
Configuration 
1. Select [USB security key] checkbox. 
2. Enter the user name and the password that exists in the HMI. 
3. The Restrict the using terms is optional. If selected, the security key is effective in the selected 
time interval. 
4. Click on [Save to USB] and navigate to the USB drive. 
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9.3. e-Mail SMTP Server Settings 

It allows e-Mail Server Settings in the HMI to be updated during runtime. The HMI programmer must 
enable e-mail function in the HMI project. (Easybuilder pro » System Parameters » [Email] tab » 
Enable email function) 
 
Configuration 
1. Select [e-Mail SMTP Server Settings] checkbox. 
2. Enter the valid SMTP Server settings. 
3. Click on [Save to USB] and navigate to the USB drive. 

 
 

 
Steps to load e-Mail SMTP Server Settings to Cmt HMI 
1. Login the Cmt web interface. 
2. Go to [Email] menu » [Import Email Accounts] tab. 
3. Navigate to the location of the file and click Update button. 
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9.4. e-Mail Contacts 

It allows e-mail contacts in the HMI to be updated during runtime. The HMI programmer must 
enable e-mail function in the HMI project. (Easybuilder pro » System Parameters » [Email] tab » 
Enable email function) 
 
Configuration 
1. Select [e-Mail Contacts] checkbox. 
2. Click the Add button to create a new contact name and its mail address to the list of contacts. Up 
to 256 contacts can be created. 
3. Create recipient groups from the No. of groups. Up to 16 groups can be created. 
4. To add a contact to the selected group. Select a group under the Current group. Then select a 
contact under the list of contacts and click on the right-arrow button.  
Click on the left-arrow button to delete the selected contact from the group. 
5. Click on [Save to USB] and navigate to the USB drive. 

 
 

Steps to load e-Mail Contacts to cMT HMI 
1. Login the cMT web interface. 
2. Go to [Email] menu » [Import Email Accounts] tab. 
3. Navigate to the location of the file and click Update button. 
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10. cMT-Viewer 
 
cMT-Viewer is a client application, which allows users to remote access the screen of cMT HMI located on 
the LAN (Local Area Network) via wireless connection or Ethernet connection.  
 
Click the button as shown below. 

 
 

Search for cMT HMIs on [Search] tab.  The available HMIs will be shown as below when existing on the 
local network. Tap an Add icon on the desired HMI, and it will bring up a window requiring you to enter the 
password.  

 
 

After that, the corresponding project will be loaded. 
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11. EasyConverter 
 
The Easy Converter is a tool used to view data log files (*.db) and event log files (*.db) that are generated by 
cMT HMI. It can convert db (database) file into CSV (comma separated values) file. 
 
11.1. Viewing Data Log File 
 
1. Launch EasyConverter. 
2. To open a data log file, click [File] » [Open] and browse a data log file. 

 
 

3. The popup window prompts you to select the date range.  

 
 

4. The following popup window appears. The raw data collected for Data 1 and Data 2 can be adjusted as 
needed. For example, the Data 2 has three digits after the decimal point. You can change the digits field 
from 3 to 1 if you’re only concerned with one decimal accuracy. 
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The Scaling column is a scaling option that offers linear scaling to data.  
The equation of scaling new value = [(value + A) x B] + C 
Set the values of A, B, and C. 
A: Lower limit of the value;  
B: [(scaled max) - (scaled min) / (upper limit) - (lower limit)]; 
C: Scaled min. 

 
 

You can click Save setting button for using these same changes on other files. The conversion file (*.lgs) 
created by Save setting button can be loaded by Load setting button, which applys the same changes on 
other files. 
 
5. Click OK, the records in the data log file is displayed as below. 
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6. To save the file as XLS file, click [File] » [Save As] or the Save As icon. 
    To save the file as CSV file, click [File] » [Export to Excel] or the Excel icon.  

 
 
11.2. Viewing Event Log File 
 
1. Launch EasyConverter. 
2. To open an event log file, click [File] » [Open] and browse an event log file.  

 
  



 28  

3. The popup window prompts you to select the date range.  

 
 

4. The following popup window prompts you to select language. 

 
 

5. Click OK, the records in the data log file is displayed as below. 
Event: This column indicates the following meanings. 
  0=Event triggered  
  1=Event acknowledged 
  2=Event returns to normal 
Category: This column indicates the event category. 
Message: This column indicates the Alarm message. 

 
 

6. To save the file as XLS file, click [File] » [Save As] or the Save As icon. 
    To save the file as CSV file, click [File] » [Export to Excel] or the Excel icon.  
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• Converting multiple files: 
This tool allows you to select multiple data/event log files and save them to one CSV file. 

1. Launch EasyConverter. 
2. Click Multiple files button to convert multiple files. 
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 3. Click [Add File] and select the files. 
Enable setting file: Check this box and browse a conversion file (*.lgs). The linear scaling conversion 
or decimal point conversion on the conversion file will be implemented to the selected data log files. 

 Combine to a file: Check this box to combine the selected files and save them into one CSV file.  

 
 

Note: [Merge data into a single sheet] is not available for data/event log files created by cMT HMI. 
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12. Recipe Editor 
 
This application is a tool which allows users to modify recipe files (*.rcp) that can update data stored in RW 
and RW_A retentive memory, as well as Extended Memory files (*.emi) that can update data stored in EM 
extended memory. 
 
1. Launch Recipe Editor. 
2. Click on [File] menu » [Open] and browse your recipe file (*.rcp) or Extended Memory file (*.emi). 

 
 

3. The following popup window appears. 
Address range (unit: word): The number of registers that are used for this file. For example, an Extended 
Memory file uses the memory EM1_0 through EM1_299. Enter 0 to “From” box and enter 299 to “To” box. 
Data format: Each data element has a format to be interpreted by the HMI. Click on the Add button to add a 
data format. 
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For example,  
The first data element on the first row is the data in String format. Enter the comment to Description box, 
selest String checkbox as well as enter how many words this string has. 
The second data element on the first row is 16-bit unsinged integer format, so select “16 bit Unsigned.” 
 
You can click on Save Format button to save this data format for using this same data format on other files.  
 
 

   In the project file     Dat format dialog  

  
 
4. After clicking OK, the below table of data elements appears. 
ID: ID number for each row. 
Address: Starting address for each row. 
Edit the table according to the data format defined for each element. 
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5. Click on [File] menu » [Save]. If the file is used to update EM external memory, you must save the file 
name which corresponds to the Extended Memory name preconfigured in the cMT HMI (em0.emi, em1.emi, 
em2.emi, em3.emi, em4.emi, em5.emi, em6.emi, em7.emi, em8.emi, or em9.emi). 
 
6. Once the file is saved, you can update the memory in the following ways: 
 

• To update RW and RW_A retentive memory, use the Download application or USB drive download. 
 

• To update EM external memory, copy the file to the external memory device or via FTP server to 
transfer. 
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13. Recipe Database Editor 
 
This application is a tool which allows users to create or modify a database file that can update Recipe 
Database stored in the .cxob project file. 
 
1. Launch Recipe Database Editor. 
2. Click on the Import button and navigate to where the Recipe DEF file (*.rdef) or Database file (*.db) is 
located. 
 
3.  

• Create a new database when importing Recipe DEF file (*.rdef). 

 
 

Click the Add button to add a new row to the database. Enter the data element according to the 
data format predefined in the .cxob project file. The up and down arrow buttons is used to move the 
selected row up and down in the list. 
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• Modify a database file when importing Database file (*.db) 
Edit the table according to the data format predefined in the .cxob project file. The up and down 
arrow buttons is used to move the selected row up and down in the list. 
 

 
 
4. Click on Export button to save this database. 
5. To update Recipe Database stored in the .cxob project file, use the Download application or USB drive 
download. 
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14. Easy System Setting 
This application is a tool which allows you to configure hardware system settings on PC. 

 
1. Launch EasySystemSetting. 

 
 

2. Select [cMT Series] from the [Model] drop-down list. Enter the HMI’s system password onto [Current 
Local Password]. (The default password is 111111) 

 
  
3. Configure system settings if required. To know the information about the following options, please refer 

to the user manual of the CMT HMIs. The unchecked options won’t update the specific settings. 
 General menu- 
   HMI name 
   Backlight (Brightness) 
   Time offset (Time zone) 
   Portrait mode 
   Volume 
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 History menu- 
   Clear Recipe 
   Clear Recipe Database 
   Clear Operation Log 
   Clear Event Log 
   Clear Data Log 
 
 Network LAN1 menu- 
    IP address  
    Subnet mask 
    Gateway 
    DNS address 
 
 Note: If [DHCP] option is checked, above options will be grayed out. 
 
 Network LAN2 menu- 
    IP address  
    Subnet mask 
 
 Note: If [DHCP] option is checked, above options will be grayed out. 
 
 Security menu- 
   Local (System setting) password  
   Upload Project password 
   Upload (History, FTP) password 
   User password 
 
 VNC server setting menu- 
   Start VNC single-connection 
   Start VNC multi-connection 
   Stop 
   VNC password 
 
   Note: If [Stop] option is chosen, [VNC password] option will be grayed out 
 
 Misc menu-  
         Popup download window 
         FTP client can modify USB/SD data 
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4. Once finishing the settings, go to [File] tab » [Save]. Save it to *.conf file. 

 
 

How to use this file 
1. In the Utility Manager, make sure the [cMT Series] option is chosen in advance. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Launch the Download application. 
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3. In the Download dialog, check  [Use system settings file]. Navigate to the *.conf file. Click Download 

button.   
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15. cMT Diagnoser 
 

This application is a tool that allows you to diagnose faults between devices. 

 
Before using this tool, the Diagnoser checkbox in your HMI project must be selected. This option can be 
found from [System Setting Parameters] » [Remote] tab. 

 
 

You can set up a password to protect the tool from unauthorized users or select Password free. 

 
 

Load the project to your HMI. 
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How to Use cMT Diagnoser 
 
Launch Utility Manager on your PC. Click [cMT Diagnoser]. 

 
 

Click the HMI. 

 
 
Enter the password to access the diagnostic tool. If [Password free] is selected in the HMI project, the 
password is NOT required. 
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On the [Object] tab, the table shows you the objects used in this window. 

 
 
You can change windows using the drop-down list. 
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The object will be highlighted in green when clicking a row on the table. 

 

 
The value of an object can be changed by double-clicking a row. For example, you can turn ON a Bit Lamp. 
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You can click “+” button to add a new address to monitor. To delete an address under Watch, select the 
address and then click on “trash bin” button. 
Note: Adding tags of tag-based PLCs is not supported.  

 
 
[Device] tab 
This page shows you the devices connected to the HMI.  
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[Packet] tab » Activity 
In this page, you can monitor a device using the Device drop-down list and then clicking the “signal” 
(orange) button or click the “signal” button to monitor all the devices. 

 
 
[Packet] tab » Polling 
This page lists packets between devices and the HMI. 
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[Macro] tab 
In this page, you can run macros to validate the functions on the devices. 

 
 
[MQTT] tab » Server 
This page shows you the state of MQTT server connected to the HMI, as well as connection logs. 
Type: The MQTT server used in this project, displaying Normal / Azure IoT Hub / Sparkplug / Google Cloud 
IoT Core. 
State: It displays Stopped/Disconnected/Connected 
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[MQTT] tab » Address 
The MQTT topics published and subscribed by the HMI are displayed in this page. You can select the 
checkbox of a topic to monitor its content (JSON or RAW format) in Published page or Subscribed page. 

 
 
[MQTT] tab » Published  
This page displays the content of MQTT topics published to the MQTT server. 
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[MQTT] tab » Subscribed 
This page displays the content of MQTT topics subscribed from the MQTT server. 
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Appendix A- FTP Server 

 
FTP (File Transfer Protocol) Server in cMT HMIs allows users to access data log files, event log files, 
operation log files, Recipe files (RW, RW_A), Recipe database files stored in the HMI internal flash memory 
or on an USB drive, as well as SD card. 
 
How to log in the FTP server 
 
1. Find the IP address of the HMI. The IP address can be found on the cMT HMI or via cMT-Viewer. Make 
sure the PC and the HMI are on the same subnet. 
 
2. On the PC, open the file explorer and enter the following address: 
 ftp://uploadhis: [FTP password]@[ the IP Address of the HMI] 
 
For instance, enter ftp://uploadhis:111111@192.168.1.100 . 111111 is the default FTP password.  
192.168.1.100 is the IP Address of the HMI. 
 
3. Press “Enter” on your keyboard. 
 
4. When the password is correct, the following folders will be displayed as shown.   

 
 

• Steps to backup data log files 
1. Click “datalog” folder to view the files. 
2. Copy and paste the files to the PC. 
 

• Steps to backup event log files 
1. Click “eventlog” folder to view the files. 
2. Copy and paste the files to the PC. 
  

ftp://uploadhis:111111@192.168.1.100/
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Reference Link:  
Weintek Labs website: http://www.weintek.com 
 

 
 
 
 

Windows is a trademark or a registered trademark of Microsoft Corporation in the United States and/or other countries.  

Other company names, product names, or trademarks in this document are the trademarks or registered trademarks of their 

respective companies.  

This document is subject to change without prior notice. 

 
 
 

 
 
 
 
 
 
  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  
 

Founded in 1996, WEINTEK LABS is a global-leading HMI manufacturer and is dedicated to the 
development, design, and manufacturing of practical HMI solutions. WEINTEK LAB’s mission is 

to provide quality, customizable HMI-solutions that meet the needs of all industrial automation 
requirements while maintaining customer satisfaction by providing “on-demand” customer service. 
WEINTEK LABS brought their innovative technology to the United States in 2016, WEINTEK USA, INC., to 
provide quality and expedient solutions to the North American industrial market. 
 
6219 NE 181s Street STE 120 
Kenmore, WA 98028          
425-488-1100  

http://www.weintek.com/

